Smart Plug installation is unreliable

Emporia Energy Community Support Center Emporia App Smart Plug installation is unreliable

Viewing 4 reply threads
  • Author
    Posts
    • #6803 Report Abuse
      george98034
      Member

      First of all, the FAQ says to use the search feature but I can’t find the search feature anywhere on the page.  It would usually be above the contents.

      I’ve owned smart plugs from Kasa and Feit and installed about a dozen without a single hitch.  Today I tried installing 4 and not a single one worked right the first time and I still can’t get two of them to work at all.

      – Why doesn’t the app list the available Wifi networks instead of defaulting to the current network or manually typing it in?  Once it didn’t work with it lower case but when I matched capitals it seemed to work.  Listing them so you can choose it would solve that.  All the competitors do that.

      – Why doesn’t the app remember the password for the network?  If you install 4 you have to type in the same password 4 times – again providing more chance for mistakes.

      – The apps says to “power off” but it doesn’t explain if that’s unplugging it or pressing the button.  I assume it should say “press the power button to turn off the device”.  But worse, you can get into a state where the power button does nothing.

      – The app has a button to take you to Wifi settings to choose the device’s hotspot, but it takes you to the wrong place.  It should take you to Settings/Wifi but it takes you to the app’s settings

      – Why are there two separate ways to setup – quick & hotspot?  Noone else does that.  While the “quick” sounds nice, in practice, it makes it much more confusing especially since the first instruction in each page leads you to the other mode.  I wish it just used the hotspot method like everyone else which works 100% of the time for them – but not for Emporia 🙁

      – Instead of constantly switching pages (connecting to plug, connecting to Wifi, getting information, etc) in what sometimes seems like a cycle, please have a single page that lists which stages it’s completed and how many are next.

      – My first plug wouldn’t work and I eventually figured it was the case.  But it left me with the plug off so I wasted a bunch of time trying to figure out whether it was done updating and why it was showing 0.  The item was a hot water dispenser so I couldn’t tell if it was on or not.

      – My second plug I did the quick setup and I think it worked but it took forever to update.

      – My third plug I went back to hotspot and it seemed to work fine until it got to the end and then just hung.  Worse yet, after that the app wouldn’t display any of the charts – it was just showing the refresh symbol.  Even after closing & restarting the app it did that.  I finally gave up on it and moved onto #4.

      – My 4th plug I was frustrated so I went back to Quick.  It seemed to work fine but then it kept cycling between the different pages and just never stopped.

      You need to make this app rock solid like Kasa & Feit.  Reducing the paths to a single option – hotspot – and giving a clear progress that doesn’t cycle back around would go a long ways to making it reliable.

    • #6850 Report Abuse
      waterboyz
      Member

      Hollee Krap.  I just went through this.

    • #6861 Report Abuse
      edk
      Member

      George,

      Having just gone through setting up 2 smart plugs over the weekend I have to agree with all that you wrote.  I especially liked the part about ” The apps says to “power off”….”,  that had me completely confused as well.  It also would have been helpful to state what color the LED should be when the socket is powered on and what color it should be when off.

      What really hurt was after giving it a name, selecting the time zone and then clicking “SAVE” …..the app just sat there, stuck on the page, doing nothing.  The first plug must have taken 4 or 5 tries before it would actually “save” and move on.   The second plug was different in that it needed a firmware update.  Of course that announcement doesn’t clear by itself when it’s finished, you just have to start over to see if it will work.

      There sure is a lot of room for improvement.  I’m about to try to set a schedule, no visuals to help here, wish me luck.

    • #6965 Report Abuse
      waterboyz
      Member

      Just spent an hour adding another Smart Plug.  Finally got the app to see it and it is listed as an input.  The tiny blue light is solid.  When I select to turn on or off the Smart Plug via the app, it thinks it is but the Smart Plug does nothing.  Randomly the Smart Plug will flash red for a second then go back to solid blue.  I’ve unplugged the Smart Plug and plugged it back in multiple times and closed and reloaded the app multiple time.  And yes, went the hotspot method as well.

      The frustration level is high.  This technology has been used for a number of years with immediate success.  Why must it be so difficult here?

      I will admit that, finally, my other 3 Smart Plugs seem to be working just fine after a few days.

    • #6969 Report Abuse
      waterboyz
      Member

      UPDATE

      My 4th Smart Plug is working now….after I let it gather its’ thoughts for the last 6 hours.

      • This reply was modified 1 year, 2 months ago by waterboyz.
Viewing 4 reply threads
  • You must be logged in to reply to this topic.